Diyargroup.ru

Ремонт Строй
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

HMI панели оператора

HMI панели оператора

You are currently viewing HMI панели оператора

Человеко-машинные интерфейсы (ЧМИ) (англ. Human-machine interface, HMI) доступны с различными аппаратными и программными функциями. Пользователи должны осуществлять выбор SCADA HMI панели оператора отталкиваясь от конкретного проекта автоматизации и его функциональности.

Конечный заказчик ожидает получить интуитивно понятный интерфейс на панели оператора, и изготовители отреагировали на это, встроив стандартные наборы интерфейсов в свои панели. Современная промышленная автоматизация не обходится без сенсорных HMI, они являются важным дополнением ко многим процессам при автоматизации машин и механизмов, расширяя возможности переключателей, кнопок и индикаторов на панели управления. Однако каждый вариант использования HMI должен тщательно оцениваться, чтобы гарантировать, что панель выбрана правильно в соответствии с требованиями технологического процесса.

Многие начинают выбор панели оператора с анализа рынка и просмотра существующих функций HMI и выбора программного обеспечения, которые на первый взгляд соответствуют потребностям. Тем не менее, более прагматичный и надежный подход заключается в обратном направлении, то есть изучении конкретных потребностей технологического процесса, чтобы подтвердить выбор всех необходимых параметров и функций.

PLCforum.uz.ua

Уважаемые коллеги, столкнулся тут с проблемой:
На работающем станке установлен S7-300, 3 блока входов и 2 блока выходов, панель управления.
Включаем питание станка.Панель загружается, программа контроллера загружается. видим такую картину.
На панели отображаются активные входа, а также активные выходы.
На контроллере же входы горят, а выходы не горят. (в реальности выходов с контроллера нет)
Например на панели показывает, что активен выход на световую колонну, но она не горит.
Если выдернуть разъем панели от контроллера и перезагрузить питание то она показывает отсутствие входов и выходов, т. е. она работает правильно судя по всему.
Проходит какое-то время (около часа) и выходы на контроллере тоже загораются (эти же что были активны на панели изначально) и все начинает работать.

Что это может быть за проблема.

Re: Проблема с S7-300

  • Quote

Post by Владимир » Wed Sep 07, 2016 10:53 am

Re: Проблема с S7-300

  • Quote
Читайте так же:
Как подключить автоматический выключатель иэк

Post by Aleks333777333 » Wed Sep 07, 2016 12:48 pm

В Санкт-Петербурге
Дело в том, что у нас отдельные блоки ввода и вывода. Я про них говорю. На них сигналы не горят, те же, что на панели.
Кроме того заметил, что если нажимаешь аварийную кнопку, то начинает гореть один из выходов на одном из блоков выходов , а когда на панели нажимаешь кнопку сброса ошибки — ошибки сбрасываются и этот выходной сигнал пропадает. Но по прежнему ничего не работает.. а на контроллере не горят те выходы которые активны на панели.
Такая проблема возникает если станок постоит с выключенным питанием более суток. (если это поможет диагностировать)

По прежнему жду совета профессионалов, что проверять, где искать.

Re: Проблема с S7-300

  • Quote

Post by Владимир » Wed Sep 07, 2016 4:07 pm

Re: Проблема с S7-300

  • Quote

Post by CoMod » Wed Sep 07, 2016 6:25 pm

Замена блока выходов 6ЕS7 322-1BL00

  • Quote

Post by Aleks333777333 » Thu Sep 15, 2016 12:16 pm

Добрый день!
Имеется контроллер Siemens S7-300 CPU314
У него много дополнительных блоков входов и выходов
Он стоит на рабочем станке, но начали появляться проблемы с одним из блоков выходов 6ЕS7 322-1BL00. А именно: при отключении питания более чем на 1 сутки, при включении питания выходы с него отсутствуют. (Описывал ниже в форуме данную проблему)
Станок работает, питание мы не выключаем, боимся, что опять не включится.

Расскажите как грамотно заменить данный блок выходов (прямо по пунктам если можно), чтобы ничего не полетело и станок завелся после моего ремонта.
Спасибо!

Re: Проблема с S7-300

  • Quote

Post by CoMod » Thu Sep 15, 2016 1:29 pm

На будущее — «общие» описания не позволяют решить конкретные проблемы.
Фотку системы выложишь ?
типа
Image

Re: Проблема с S7-300

  • Quote

Post by Aleks333777333 » Thu Sep 15, 2016 2:33 pm

вот:
Image

Re: Проблема с S7-300

  • Quote
Читайте так же:
Аварийный выключатель дверей это

Post by CoMod » Thu Sep 15, 2016 2:45 pm

Re: Проблема с S7-300

  • Quote

Post by Владимир » Thu Sep 15, 2016 5:52 pm

Re: Проблема с S7-300

  • Quote

Post by Aleks333777333 » Fri Sep 16, 2016 6:18 am

Re: Проблема с S7-300

  • Quote

Post by Aleks333777333 » Fri Sep 16, 2016 6:31 am

Я вот не знаю, оба ли модуля ведут себя аналогично. Ведь на 1 модуле сигналов и не должно быть изначально при включении станка.
Питание приходит.
Более того если нажать аварийную кнопку. То загорается один из выходов на первом блоке выходов.(это красная лампа световой колонны). Но другие выходы не горят. (Те которые должны гореть при включении и которые отображаются активными на панели управления) Панель управления общается с центральным блоком по Profibus. Отсюда делаю вывод, что проблемы с блоком выходов.
Станок Турецкий, работает уже 3 года.

Подключится и посмотреть буфер диагностики дадут во вторник с утра. Станок работает без перерывов.

Re: Проблема с S7-300

  • Quote

Post by Aleks333777333 » Fri Sep 16, 2016 7:18 am

Вот такое отображение состояний входоввыходов на панели:
Image
Image
На блоках входов контроллера оно такое же, а на блоках выходов контроллера сигналов вообще нет. А при нажатии аварийной кнопки появляется сигнал Q17.0
Странно, ведь сигналы Q16.0-Q19.7 — это сигналы с одного блока выходов. И почему Q17.0 «доходит», а остальные нет?
Примерно через час, два, находясь во включенном состоянии сигналы выходов Q16.3, Q16.4, Q16.5, Q16.6, Q17.1 появляются сами собой.

Что делать, что еще проверять?

Может кто-нибудь скинуть картинку, как правильно снимаются эти блоки выходов, хочу проверить соединения. Погуглил, но не нашел ответа.

Re: Проблема с S7-300

  • Quote

Post by Rex2701 » Fri Sep 16, 2016 9:04 am

Re: Проблема с S7-300

  • Quote

Post by Владимир » Fri Sep 16, 2016 9:13 am

Re: Проблема с S7-300

  • Quote

Post by Владимир » Fri Sep 16, 2016 9:19 am

Читайте так же:
Какой фирмы покупать автоматические выключатели

Re: Проблема с S7-300

  • Quote

Post by Aleks333777333 » Fri Sep 16, 2016 9:55 am

Re: Проблема с S7-300

  • Quote

Post by Владимир » Fri Sep 16, 2016 10:51 am

Re: Проблема с S7-300

  • Quote

Post by Aleks333777333 » Fri Sep 16, 2016 10:54 am

Re: Проблема с S7-300

  • Quote

Post by Aleks333777333 » Wed Sep 21, 2016 11:38 am

Re: Проблема с S7-300

  • Quote

Post by Владимир » Wed Sep 21, 2016 1:52 pm

Не спешите с монтажкой в контроллер лезть.
Давайте еще раз. Когда все плохо.
1. На панели на экране с отображением выходных дискретных сигналов есть индикация о том, что какие-то выходы включены?
2. В это же время на самом модуле индикаторы не светятся?
3. В это же самое время на общем проводе, который подходит к модулю, есть напряжение?

Если все так, и внутрь ПЛК Степом7 не залезть для повторной проверки всего этого, то пробуйте менять модули местами, как описывал раньше.

Re: Проблема с S7-300

  • Quote

Post by Aleks333777333 » Wed Sep 21, 2016 3:32 pm

Re: Проблема с S7-300

  • Quote

Post by Владимир » Wed Sep 21, 2016 7:55 pm

Re: Проблема с S7-300

  • Quote

Post by Aleks333777333 » Thu Sep 22, 2016 6:57 am

Re: Проблема с S7-300

  • Quote

Post by CoMod » Thu Sep 22, 2016 7:19 am

Re: Проблема с S7-300

  • Quote

Post by Владимир » Thu Sep 22, 2016 7:43 am

Re: Проблема с S7-300

  • Quote

Post by Aleks333777333 » Thu Sep 22, 2016 7:57 am

Re: Проблема с S7-300

  • Quote

Post by CoMod » Thu Sep 22, 2016 8:00 am

Требуется разрешение
Хотите просмотреть файл? Свяжитесь с его владельцем или войдите в аккаунт с правом доступа

Re: Проблема с S7-300

  • Quote

Post by Aleks333777333 » Thu Sep 22, 2016 8:25 am

Re: Проблема с S7-300

  • Quote
Читайте так же:
Моторный привод автоматического выключателя что это

Post by Владимир » Thu Sep 22, 2016 11:42 am

Re: Проблема с S7-300

  • Quote

Post by Aleks333777333 » Thu Sep 22, 2016 12:22 pm

Re: Проблема с S7-300

  • Quote

Post by Владимир » Thu Sep 22, 2016 1:24 pm

Re: Проблема с S7-300

  • Quote

Post by Aleks333777333 » Thu Sep 22, 2016 2:57 pm

Если вы про network:10 в OB1
Так там если ниже 20 градусов — выключить охлаждение
если выше 30 градусов — включить охлаждение

или вы про что-то другое?

Подогрева масла в гидравлике у нас точно нет. Только охлаждение.

Вот ссылка на проект на яндекс -диске, если кто сможет разобраться: https://yadi.sk/d/rsQLkMmSvZ4Qu

Re: Проблема с S7-300

  • Quote

Post by Владимир » Thu Sep 22, 2016 5:32 pm

Re: Проблема с S7-300

  • Quote

Post by Aleks333777333 » Thu Sep 22, 2016 6:00 pm

Re: Проблема с S7-300

  • Quote

Post by Владимир » Thu Sep 22, 2016 7:46 pm

Нууу. Опыт дело наживное, но и все знать невозможно. В таблице символов не всегда все каналы описаны. Смотрите в Cross Referens использованные адреса. Но и там может быть не все. Бывает косвенная адресация, бывает некие каналы ввода-вывода используются напрямую в панели и никак не упоминаются в программе ПЛК, а бывает по сети какой-нибуль неявным образом управляется выход или читается вход. Вы можете не видеть в программе ПЛК всей картины.

У вас в проекте есть таблица VAT_1, вы сами его создавали? Важно.

А по поводу стиля написания программы. Вы же сами сказали, станок турецкий. Пока мы покупаем их поделки, у меня всегда работа будет. Не далее как месяц назад токарный расточной пытался заставить адекватно работать. Итог, вся программа новая до последней строчки и с десяток проводных связей в щите, которые должны были быть там с самого рождения станка.
Комментарии в «слитых» программах — редкость. Все больше паролей, чем подсказок. Привыкайте.

Читайте так же:
Как собрать выключатель с диодами

Re: Проблема с S7-300

  • Quote

Post by CoMod » Thu Sep 22, 2016 8:27 pm

Выложенная на яндексе программа нормального качества — на языке ЛАД «комментарии» содержатся в названии Ветки и в именах тэгов — и то и другое присутствует.
Что то видимо вставляли при пусконаладке и поэтому осталось без имени.

Какие конкретно адреса глючат ?
Image

Времени нет и не предвидится. а тут ещё и Касперский в который раз нашёл «заразу» во Флексе

Re: Проблема с S7-300

  • Quote

Post by Aleks333777333 » Fri Sep 23, 2016 6:41 am

Владимиру
Нет, конечно, программу писал не я. И Vat_1 тоже создавал не я. Я только добавлял в нее таймер счета заготовок. Это в самом конце OB1. Да и то это было в августа 2015г. С тех пор в этот коннтроллер никто не лазил. Это точно. А проблемы начались в конце августа этого года.
Мне бы вот понять какие еще критерии могут повлиять на отсутствие включения выходов на контроллере. Смотрю FC1 там все ошибки сводятся к каким-то тегам или символьным переменным, а дальше не понятно, что смотреть.
CoMod
После сброса ошибок должны включаться Q16.3 Q16.5 ну и либо Q17.1 либо Q 18.7 это световая колонна характеризующая ручной или автоматический режим соответственно. (через час, два когда они включаются далее все работает без проблем)

Ладно, не буду ныть больше, попробую еще порыть как дадут возможность. Хочу просто максимально подготовиться к этому времени.

Думал тут полночи. Очень хочу проверить FC1 Network 44 и 45: Думаю может датчик температуры отваливается и выдаёт большое значение — отсюда и вся беда.

Re: Проблема с S7-300

  • Quote

Post by CoMod » Fri Sep 23, 2016 7:30 am

Re: Проблема с S7-300

  • Quote

Post by Aleks333777333 » Fri Sep 23, 2016 9:00 am

голоса
Рейтинг статьи
Ссылка на основную публикацию
Adblock
detector